You need Flash Player 9.0 or above to use the new system.

Free download of Flash Player is available at http://www.adobe.com/go/getflash

Thank you for helping us keep your data safe,

ImPACT Team